Importing Trusted Certificates onto Legacy Wyse WinTerms

Overview

Root Certificates are used by web browsers to identify a trust with web sites. When root certificates expire, Windows usually auto-updates them (Vista and above) or deploys them through Microsoft Update (Windows XP). The Windows CE 5 operating system on the Wyse 3150 WinTerm (windows terminal) has no automatic way of updating them so they must be imported manually.

We had this situation arise when our remote users complained that they were unable to log on to one of our Citrix Servers. All they would get was an SSL Error 70 message when they tried to load the virtual desktop. Luckily, one of the more up to date terminals gave a more specific error, stating that one of the certificates, from GlobalSign, had expired. So my challenge became to get the latest one imported manually.

Continue reading Importing Trusted Certificates onto Legacy Wyse WinTerms